Demo & Step by Step Guide

Using PowerPivot in MS Excel
to analyze SQL Server Data

By: Wylie Blanchard - Great Tech Pros

e Use a Bl Semantic Model Connection in Excel
e Analyze Data & Present Data with PowerPivot & Power View

Use a Bl Semantic Model Connection
In Excel

Creating a Tabular Model Project

Open SQL Server Data Tools (Visual Studio)
Go to File > New > Project
Select project type Analysis Services Tabular Project
Insert the name of your Analysis Services Tabular instance
An empty model, Model.bim file is created
Go to Model > Import From Data Source

a. The Table Import Wizard window opens
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7.

Select the Microsoft SQL Server option

Table Import Wizard ?

Connect to a Data Source
You can either create a connection to a data source, or you can use one that
already exists.

Microsoft SQL Server

Create a connection to a SQL Server database. Import tables or views from the database, or data
returned from a query.

Microsoft SQL Azure

Create a connection to a SQL Azure database. Import tables or views from the database, or data
returned from a query.

Microsoft Analytics Platform System

Create a connection to a Microsoft Analytics Platform System. Import tables or views in the database,
or data returned from a query.

Microsoft Access

Create a connection to a Microsoft Access database. Import tables or views from the database, or data
returned from a query.

Oracle

Create a connection to an Oracle database. Import tables or views from the database, or data
returned from a query.

Teradata

Create a connection to a Teradata database. Import tables or views from the database, or data
returned from a query.

Sybase
Create a connection to a Svbase database. Import tables or views from the database. or data returned

v

< Back Next > Finish | Cancel

11.

On the Connect to a Microsoft SQL Server Database screen, Insert the server name
of your Data Warehouse (SQL Server) instance and then select the name of the
database from the drop down box

Click Next, and insert your connection on the prompting screens

On the Select the Source Tables and Views screen place a checkmark next to each
tables and views that you want to include in your project
Click Finish




Table Import Wizard ? X

Select Tables and Views
Select the tables and views that you want to import data from.

server: [N

Database: AdventureWorksDW2012

Tables and Views:

L | Source Table Schema Friendly Name Filter Details ~
[ ]E= | AdventureWorksDWBuildVers... | dbo

[ ]2 | DatabaseLog dbo

[ 1= | DimAccount dbo

[ 1= | DimCurrency dbo

B | DimCustomer dbo Customer

I | DimDate dbo Date

[ ]2 | DimDepartmentGroup dbo

||:| B | DimEmployee dbo

' B | DimGeography dbo Geography

[ ]2 | DimOrganization dbo

= | DimProduct dbo Product

£ | DimProductCategory dbo Product Category

| DimProductSubcategory dbo Product Subcategory

[]®= | DimPromotion dbo v

‘ Select Related Tables ‘ ‘ Preview & Filter ‘

< Back | Next > Finish | Cancel ‘

12. Optionally, you can preview your data before moving




Table Import Wizard 7 kY

Preview Selected Table
Use the checkbox to select specific columns. To filter the data in a column, use the drop-down arrow for the column to select values that should be included.

Table Name: FactlnternetSales

[ =TT [ OrderDat... - [ DueDat... - [ ShipDat... - [ Custom... ~ [ Promotio... ~ [ Currenc... ~ [ SalesTerritor... ~ [ SalesOrderNu... ~ [ Saler &
1 310 20050701 20050713 20050708 21768 il 19 6 5043697
o 346 20050701 20050713 20050708 28389 d, 39 7 5043698
3 346 20050701 20050713 20050708 25863 1 100 1 S043699
4 336 20050701 20050713 20050708 14501 il 100 45043700
5 346 20050701 20050713 20050708 11003 ik 6 9 5043701
6 Sk 20050702 20050714 20050709 27645 A 100 45043702
7 310 20050702 20050714 20050709 16624 1 6 9 5043703
8 351 20050702 20050714 20050709 11005 1 6 9 5043704
9 344 20050702 20050714 20050709 11011 1 6 9 5043705
10 3 20050703 20050715 20050710 27621 1) 100 4 5043706
11 312 20050703 20050715 20050710 27616 1 100 4 5043707
12 330 20050703 20050715 20050710 20042 1 98 10 5043708
1% 313 20050703 20050715 20050710 16351 a1k 6 9 5043709
14 314 20050703 20050715 20050710 16517 1 6 9 5043710
15 214 InNsN7na Innsn71A 20ns0711 27606 1 10n 1 cnar711
< > v

Clear Row Filters Cancel

Table Import Wizard ? had

Importing
The import operation might take several minutes to complete. To stop the import
operation, click the Stop Import button.

‘o Total: 7 Cancelled: 0
Success
Success: 7 Error: 0
Details:
| Work Item Status Message
@ Customer Success. 18,484 rows transferred.
.9 Date Success. 2,191 rows transferred.
@ Geography Success. 655 rows transferred.
@ Product Success. 606 rows transferred.
@ Product Category Success. 4 rows transferred.
.0 Product Subcategory Success. 37 rows transferred.
@ Internet Sales Success. 60,398 rows transferred.
@ Data preparation Completed Details

Close




13. Final view of the model (below) - note the tabs at the bottom of the screen

Debug  Model Table Column Team Tools Test Analyze Window Help Wylie Blanchard ~

> ~ | Develop ~ ~| P Start '| - a a E ,;'E Select Perspective  <Default> - P ﬁl =] Ql o - E - il

Model1.bim* # X

~ | Solution Explorer

>
[Customer... ~ fx‘ ‘V Gﬁ ,@ -5 0 = r@ | ﬁ =
4 Custom... B - Geograph... Bn - CustomerAlternateKey - Title ~ FirstName - MiddleName =~ LastName - NameStyle - (f
1 11602 135 AW00011602 Larry Gil FALSE Search Solution Explorer (Ctrl+;) P~
2 11603 244 AW00011603 Geoffrey Gonzalez FALSE | m Solution TabularProject3' (1 project)
3 11610 269 AW00011610 Blake Collins FALSE 4 (2 TabularProject1
I je
4 12517 133 AW00012517 Alexa Watson FALSE | 8 References
5 12518 161 AW00012518 Jacquelyn Dominguez FALSE - ;
5 12510 265 AW00012519 Casey Gutierrez FALSE ¥ Model1.bim
% 12714 157 AW00012714 Colleen Lu FALSE
8 12728 131 AW00012728 Jeremiah Stewart FALSE
9 12871 233 AW00012871 Leah Li FALSE
10 13671 173 AWO00013671 Frank Ramos FALSE
11 13826 127 AW00013826 Candice He FALSE
12 13830 237  AW00013830 Andrea Cox FALSE
13 13838 263 AW00013838 Jill Rubio FALSE
ik 14838 121 AWO00014838 Darren Alvarez FALSE
15 14839 238 AW00014839 Natasha Sanz FALSE Solution Explorer VTeam S ey
16 14840 277 AW00014840 Autumn Zhu FALSE
17 14848 186 AW00014848 George Louverdis FALSE T
18 14849 142 AW00014849 Dwayne Martin FALSE
19 14901 272 AW00D14991 Edwin Zhao FALSE Sustomenlabls i
16317 263 AW00016317 Joel Raman FALSE AT
16452 232 AW00016452 Cassie Luo FALSE Eormiila -
22 16453 271 AW00016453 Mayra Chandra FALSE = Hidden Ealse
 — | ~ |0 Partitions (Click to edit)
Source Data (Click to edit}
Table Description
Table Name Customer
4 » |F Rennrtina Pronerties h
Customer | Date GeographyJ ProductJ Product Category J Product Subcategory J Internet Sales J:ﬁ Table Name
Record: 1€ € 1 of 18,484 > 3 The name of the table, as it is stored in the model

Deploy the Tabular Model

—_—

Right-click the project name

2.  select Properties
a. Properties box opens
3.  Ensure that the Server property displays the name of your Tabular instance
4. Click Ok
5.  Go to Build > Deploy TabularProject 1 (the name of your project)
6.  Your project is now deployed to the server



Deploy ? X
Deploying

The deployment operation may take several minutes to complete.

8 Total 0 Cancelled

‘o

Success
8 Success 0 Error
Details:
Work Item Status Message
:h Deploy metadata Success. Metadata deployed. _:
@ Customer Success. 18,484 rows transferred.
@ Date Success. 2,191 rows transferred.
@ Geography Success. 655 rows transferred.
@ Product Success. 606 rows transferred.
@ Product Category Success. 4 rows transferred.
@ Product Subcategory Success. 37 rows transferred.
@ Intemnet Sales Success. 60,398 rows transferred.

Analyze & Present Data with PowerPivot &
Power View

Activate PowerPivot MS Excel add-in

Open MS Excel 2013

Go to File > Options > Add-Ins

In the Manage box, click COM Add-ins> Go

Check the Microsoft Office PowerPivot & Power View boxes

=own =



COM Add-Ins

? X
Add-Ins available:
[ ]inguire )
:\2] Microsoft Office PowerPivot for Excel 2013 ‘ Cance| [
[ Microsoft Power Map for Excel -
Z‘ Power View

:‘Team Foundation Add-in

Remove

C\Program Files\Microsoft Office 15\Root\Office15\ADDINS\PowerPivot Excel Add-in\PowerPivotExcelClientAddin.dll
Load Behavior: Load at Startup

Location:

PowerPivot tab

1. Click the Power Pivot tab

a. This is the tab where you work with Power Pivot PivotTables, calculated fields,
and key performance indicators (KPIs), and creating linked tables
2. Click Manage to open the PowerPivot window to manage data

BEBHS9S @3-+

FILE HOME  INSERT  PAGE LAYOUT FORMULAS DATA  REVIEW  VIEW = POWERPIVOT

r@:l jﬂ @ 2| Align Vertically @ mm D& a'ﬂ

;EE’;AIign Horizontally

Book1 - Excel

"l

-

=
Manage Calculated KPlIs Addto Update Detect  Settings
Fields - v Data Model  All
Data Model Calculations Slicer Alignment Tables

Relationships

3. Click the Power Pivot tab

EEHS9S @8-+

FILE HOME  INSERT  PAGELAYOUT FORMULAS DATA  REVIEW VIEW = POWERPIVOT

Bl ar : %
i, Align Vertically &
b =1 -
|@ Jx @ i = s o

— Align Horizontally =’
Manage Calculated KPIs

Addto Update  Detect
Fields - -

Data Model  All
Data Model Calculations Slicer Alignment Tables

Book1 - Excel

Settings

Relationships



4. Click Manage to open the PowerPivot window

B ooEE = | PowerPivot for Excel - Book1
Home Design Advanced
okl [ Data Type : ~ H AutoSum ~ ’j1 r:tg Diagram View
1 Lt (i

L/ Format: ~ Create KPI - _Uj Show Hidden

Paste Get External Refresh  PivotTable Clear All  Sortby Find Data
Data™ ' i 2 Filters  Column ~ View Calculation Area

Clipboard Formatting Sort and Filter Find Calculations View

Import Data from SQL Server

1. In the Power Pivot window, click Get External Data > From Database > From SQL
Server

2. In Connect to Microsoft SQL Server Database, in Server or File Name, enter the
name of SQL Server instance where your Data Warehouse is located.

3.  Click the down arrow to the right of the Database name list, and select an Analysis
Services database from the list

4. Click Test Connection to verify that the server is available.
Click Next



Table Import Wizard ? X

Connect to a Microsoft SQL Server Database

Enter the information required to connect to the Microsoft SQL Server database.

Friendly connection name: ]SqIServer LAPTOP-P3AJK7V7 AdventureWorksDW2012

Server name: LAPTOP-P3AJKIVI v

Log on to the server

(®) Use Windows Authentication

() Use SQL Server Authentication

User name: ]
Password: |
Database name: |AdventureWorksDW2012 v
Advanced Test Connection
< Back Next = Einish Cancel

6. Onthe Choose How to Import the Data screen click the radial button for Select from a
list of tables and views to choose the data to import
7.  Click Next
8.  Select the tables and views that you want included.
a. You can change any Source Table name to Friendly Name
b.  You can click Preview and Fllter to exclude columns and data
9.  Click Finish to complete import process




Table Import Wizard
Select Tables and Views

Select the tables and views that you want to import data from.

Server: LAPTOP-P3AJKZVT
Database: AdventureWorksDW2012

Tables and Views:

[ Source Table Schema Friendly Name Filter Details A
] |? AdventureWorksDWBuildVersion |dbo

[ ] | Databaselog dbo

[ ]= | DimAccount dbo

[ ] | DimCurrency dbo

|@ DimCustomer dbo Customer

[V | DimDate dbo Date

D|@ DimDepartmentGroup dbo

[ ] | DimEmployee dbo

& | DimGeography dbo Geography

[ ] | DimOrganization dbo

[V | DimProduct dbo Product

|@ DimProductCategory dbo Product Category

|@ DimProductSubcategory dbo Product Subcategory

D|@ DimPromotion dbo

1= | DimReseller dbo ¥

Select Related Tables ‘ ‘ Preview & Filter

< Back

Next >

Einish

Cancel




Table Import Wizard ?
Imporiing
The import operation might take several minutes to complete. To stop the import operation, click the Stop Import button.
Q Total: 7 Cancelled: 0
Success
Success: 7 Emor: 0
Details:
| Work ltem Status Message
9 Customer Success. 18,484 rows transferred.
& Date Success. 2,191 rows transferred.
@ Geography Success. 655 rows transferred.
@ Product Success. 606 rows transferred.
@ Product Category Success. 4 rows transferred.
@ Product Subcategory Success. 37 rows transferred.
@ Internet Sales Success. 60,398 rows transferred.
@ Data preparation Completed Details
Stop Import Close

Completed Data Import (below)



= | PowerPivot for Excel - Book1

Formal

.0 .00

$-% > Tk

Formatting

Larry
Geoffrey
Blake
Alexa
Jacquelyn
Casey
Colleen
Jeremiah
Leah
Frank
Candice
Andrea
Jill
Darren
Natasha
Autumn
George

File Home Design Advanced
s | | 3 > 2
Paste Replace L 2~
Paste From From Data From Other  Existing Refresh  PivotTable
o Database = Service™ Sources Connections ¥ ¥
4 Get External Data
|[Custem... ~ £
B - - -
b 11602 135 AW00011602
11603 244 AWO00011603
11610 269 AWO00011610
12517 133 AWO00012517
12518 161 AWO00012518
12519 265 AWO00012519
12714 157 AW00012714
12728 131 AWO00012728
12871 233 AWO00012871
13671 173 AWO00013671
13826 127 AW00013826
13830 237 AWO00013830
13838 263 AWO00013838
14838 121 AWO00014838
14839 238 AW00014839
14840 277 AW00014840
14848 186 AWO00014848
]
<
Customer |Date Geography | Product | Product Category | Product Subcategory | Internet Sales
Record: W + 1 of 18,484 yon

Gill

Gonzalez

Collins
Watson
Dominguez
Gutierrez
Lu
Stewart
Li

Ramos
He

Cox
Rubio
Alvarez
Sanz
Zhu

Louverdis

i

Find

FALSE
FALSE
FALSE
FALSE
FALSE
FALSE
FALSE
FALSE
FALSE
FALSE
FALSE
FALSE
FALSE
FALSE
FALSE
FALSE
FALSE

¥ Autosum * | |

Data
View

Calculations

4/13/1977 ...
2/6/1977 1...
4/23/1975 ...
8/25/1977 ...
9/27/1977 ...
12/17/197...
7/17/1973 ...
6/26/1979 ...
10/6/1976 ...
2/7/1974 1...
11/25/197...
8/3/1977 1...
6/27/1976 ...
7/26/1977 ...
5/18/1977 ...
10/23/197...
9/10/1975 ...

Diagram View - Table Relationships

Diagram Show Calculation
View Area

LT T T ¥ R SV 7 RV v S RV B V7 B RV R 7 V. )

Hidden

zE-ETEE T E TR Bz Bz

larry
geof
blaki
alexi
jacg!
case
colle
jerer
leah
fran
canc
andr
jilli2g
darr
nata
autu

geor

v

A



@ @l © - = |PowerPivot for Excel - Book1.xlsx . ¢
Home Design Advanced - @

Display: lculated Fields Hierarchies KPls

[T DateKey

[ FullDateAlternatek...
[ DayNumberOfWeek
[ EnglishDayNameOf...

™ SnanishNavName ¥

= Internet Sales

[ ProductKey
[T OrderDateKey
F7 DueDateKey
[ ShipDateKey

7 ProductKey
T productAlternateKey
] ProductSubcategor...
7 WeightUnitMeasur...
1 CustomerKey 1 SizelInitMeasureC i
™ Geographykey

= Product Subcatego...

T Customerkev

] ProductSubcategor... &
1 ProductSubcategor...
1 EnglishProductSub...
F1 spanishProductSu...

= Customer

Create a PivotTable

1. While in PowerPivot click the PivotTable button

2.  Onthe Create PivotTable screen select New Worksheet
a. A new PivotTable Worksheet is created

3.  Under PivotTable Fields do the following
a. Go to Product. Select ModeIName
b.  Go to Internet Sales. Select OrderQuantity

4. Give it a title

5. Complete. You've created a PivotTable



E: = - s Book1.xlsx - Excel PIVOTTABLE TOOLS 7T @E_ 8 X
FILE HOME INSERT PAGE LAYOUT FORMULAS DATA REVIEW  VIEW  DEVELOPER POWERPIVOT ANALYZE DESIGN Wylie Blanchard ~
€10 fe | 328 v
A B C D G H . X

: PivotTable Fields ~ *
2 ACTIVE  ALL

3 Row Labels ~ Sum of OrderQuantity Choose fields to add to <
4 All-Purpose Bike Stand 249 report:

5 Bike Wash 908 weigne .
6 Classic Vest 562 DaysToManufacture

¥ (&

yeling Cap 20 Productline

8 Fender Set - Mountain 2121 7

9 Half-Finger Gloves 1430 dealerPrice

10 Hitch Rack - 4-Bike 328) Class

1 HL Mountain Tire 1396 D Style

12 HL Road Tire 858  ModeaNanie

13 Hydration Pack 733

14 LL Mountain Tire 862 Largebhoto -
15 LL Road Tire 1044 =

16 Long-Slesve Logo Jersey 1736 Drag fields between areas below:
17 ML Mountain Tire 1161 Y FILTERS Il coLumns
18 ML Road Tire 926

19 Mountain Bottle Cage 2025

20 Mountain Tire Tube 3095

21 Mountain-100 396

22 Mountain-200 3552 ROWS ¥ VALUES

23 Mountain-400-W 543 7

24 Mountain-500 479 ModelNa... ¥ Sum of Or... ¥
25 Patch kit 3191

26 Racing Socks 568

27 Road Bottle Cage 1712 =

i S};eetéﬁ 5Reét‘\ () T 4 3 Defer Layout Upda...

S

il W -+ 100%

Add a Hierarchy

N —

© XN o s w

10.
11.
12.

13.

In PowerPivot go to table/sheet Geography
Click the Diagram View button
a. Find the Geography table in the Diagram View
Right Click the table and then Select Create Hierarchy
Rename the “Hierarchy” to “Region Hierarchy”
Drag EnglishCountryRegionName to “Region Hierarchy”
Drag StateProvinceName to “Region Hierarchy” underneath EnglishCountryRegionName
Click the Data View button
Go back to your pivot table
Under PivotTable Fields do the following
a. Go to Geography. Select Region Hierarchy
b.  Region Hierarchy appears in the ROWS section.
Drag Region Hierarchy from the ROWS section to the COLUMNS section
Filter PivotTable to display only the United States
Click the save button, name the workbook “SQLSatIndy-PowerPivotExcelSQLAnNalysis”
and close the workbook
Complete. You've created a Hierarchy and added it to your PivotTable



ELS- L R Book1.xlsx - Excel PIVOTTABLE TOOLS 7 H - 7 X

m HOME  INSERT  PAGE LAYOUT FORMULAS DATA  REVIEW VIEW DEVELOPER POWERPIVOT ~ ANALYZE  DESIGN Wylie Blanchard -
c6 - J 354 v
A B C D E G H I J K =l ;
= Grder Guanity PivotTable Fields ™ *
2 ACTIVE  ALL
3 Sum of OrderQuantity Column Labels ¥ Choose fields to add to =
4 Row Labels * = United States Grand Total report:
5 All-Purpose Bike Stand 85 85 (==
Customer -
6 Bike Wash 354] 354
7 Classic Vest 229 229 b EfDate
8 Cycling Cap 680 680 4 [T Geography
9 Fender Set - Mountain 989 989 I || Region Hierarchy T
10 Half-Finger Gloves 538 538 X =
-1 More Fields
1 Hitch Rack - 4-Bike 141 141
12 HL Mountain Tire 662 662 I £ Internet Sales
3 HL Road Tire 343 343 b T2 Product
14 Hydration Pack 273 273 — s
15 LL Mountain Tire 301 301 ;
16 LL Road Tire 286 286 Drag fields between areas below:
17 Long-Sleeve Logo Jersey 697 697 Y FILTERS I coLUMNS
18 ML Mountain Tire 440 440 Region Hi
eqgion Hi. i}
19 ML Road Tire 234 234 ¢
20 Mountain Bottle Cage 827 827
21 Mountain Tire Tube 1329 1329
22 Mountain-100 95 95 ROWS ¥ VALUES
23 Mountain-200 1261 1261
24 Mountain-400-W 212 212 Merielal, ~| | Sumaten, ™
25 Mountain-500 180 180
26 Patch kit 1165 1165
27 Racing Socks 237 237 =
= S};eet.}- Siw(‘r:ﬂ ® o S y ’ Defer Layout Upda...

it M -—§——+ 100%
10:28 AM

-z ) B E

8/13/2016

Optional: SASS to Power View Quickly

Open MS Excel

Create a blank workbook

Go to Data > From Other Sources > Get External Data > From Analysis Services
. In the Connect to Database Server screen, in Server Name, enter the name of SQL

PoObN=

Server Analysis instance where your Tabular Model was deployed.

o

Select your Tabular Model

6. Select Next, then click Finish



Data Connection Wizard ? *

Select Database and Table

Select the Database and Table/Cube which contains the data
YOu want,

Select the database that contains the data you want:
TabularProject_wylie_597b15c0-1982-42230-add-aa792a?5019d =]

|7| Connect ta a specific cube ar table:

Mame Description  Modified Created  Type

¥ /12/2016 3:36:50 AM CUBE

< >
Cancel = Back Mewt = Einish

7. On the Import Data screen, select Power View Report
8.  Excel creates a Power View Sheet with your tabular data model in the Field List.

Wk & Book1 - Excel ?E O X
FILE HOME INSERT  PAGE LAYOUT  FORMULAS DHATA REVIEW  VIEW DEVELOPER  POWER VIEW  POWERPIVOT Wylie Blanchard ~

Filters ¢ % Power View Fields x =
iew A ALL

1+ [T GirmProductCategory

I+ ] DimProductSubcatagony

DOrag Helds hetween areas balows

| news
Sheet1 | Power View1 ® ) | '

9. In the Power View Fields list do the following
a. Go to Product. Select ModelName

b. Go to Internet Sales. Select OrderQuantity
10.  Click where it says, “Click here to add a title” and type in “Order Quantities by Model
Name”.
11.  Click the save button, name the workbook “SQLSatindy SSAStoPower View” and close



the workbook
12. Complete, you've created your first Power View report using your SSAS Tabular Model

Q ( N Book1 - Excel ?THEH - O X
HOME INSERT PAGE LAYOUT FORMULAS DATA REVIEW  VIEW DEVELOPER POWER VIEW POWERPIVOT Wylie Blanchard ~
. Filters ¢« x Power View Fields x |2
Order Quantities by Model Name o AcvE | AL
[]% Freight
ModelName Order [] oOrderdate
All-Purpose Bike Stand [] % OrderDatekey
Bike Wash |: ¥ OrderQuantity
Classic Vest []% Productkey
Cyciing Cap

[]% ProducstandardCast

Fender Set - Mountain

PromotionKey

Half-Finger Gloves
Hitch Rack - 4-Bike RevisionNumber

HL Mountain Tire []% salestmount
HL Road Tire

Hydration Pack

[ 1% salesOrderLineNumber
:7j SalesOrderMumber

LL Mountain Tire

LL Road Tire
Long-Sleeve Logo Jersey
ML Mountain Tire

ML Road Tire

Drag fields between areas below:

FIELDS

Sheet1 | Power View1 ® ] »

Adding a Calculated Column using DAX

Reopen the previously saved workbook “SQLSatIindy-PowerPivotExcelSQLANalysis”
Go to the PowerPivot tab at the top of the Workbook
Click the Manage button
Go to a table (“InternetSales”)
Click a blank column click “Insert Column”
a. lts default name is CalculatedColumn1. By right-clicking on the heading, the
following options are presented:

Al S A



\
am CalculatedCalumnt vl Add Calumn
= Create Relationship..

I

. 8/8/2007 12..

8/9/2007 12 % Navigate to Related Table
.. 8/11/2007 1... o Copy

8/11/2007 1 B Insert Column

8/12/2007 1 =f Delete Columns

8/14/2007 1... Rename Column
o 1 Freeze Columns
Unfreeze All Columns
Hide from Client Tools
= Column Width...
— Filter

nternet Sales s
— Description...

3.  Select the “Rename Column” option and enter TotalProfit as the new column name
4. Create a formula that will subtract the unit price (selling price) from the product cost
(cost to create/sell product) to arrive at the total profit.
a. DAX formula =[UnitPrice]-[ProductStandardCost]

7 | PoweerPivat for becel - Boak xlse = ml

Design

LE
o Cther Existing Refesh  Pivotlabie
Spurces  Connections ]

~[TotalProfit ~| add cotumn

524.48 4/19/2008 1... 5/1/2008 ... 4/256/2008 ... $15.33
£5.16 524.49 $1.96 50,61 4/20{2008 1., 5/2/2008.. 4/27/2008.. £15.33
523.75 563.50 55,08 51.59 42172008 1., 5/3/2008 ... 4/28/2008.. 339.75
5018 524.48 51.96 50,61 4/21f20081... 5(3/2008 .. 4/28/2008... $15.33
52375 5$63.50 $5.08 §1.58 4/23/2008 1... 5/5/2008 ... 4{30/2008... $39.75
58,16 524.49 $1.96 50.61 4/25/2008 1... 5/7/2008 ... 5/2{2008 1. :$15.33
$23.75 563.50 55,08 51.59 4/26/2008 1., 5/8/2008 ... 5/3/20081... 539.75
520,57 554.99 54.40 51.37 5/1/200812..; 5/13/2008.. 5/8/20081... $34.42
520,57 §54.98 $4.40 §1.37 5/1/2008 12.., 5/13/2008... 5/8/20081.. $34.42
544.88 5120.00 58,60 53.00 5/3/2008 12... '5/15/2008... 5/10/2008... 575.12
544.88 5120.00 59.60 53,00 5/3/2008 12... 5/15/2008... 5/10/2008... £75.12
544,88 5120.00 59.60 53.00 5/4/200812... 5/15/2008... 5/11/2008... £75.12
52375 $63.50 $5.08 $1.59 5/5/2008 12... 5/17/2008... 5/13/2008... £39.75
544.88 $120.00 $2.60 £3.00 5/6/200812,., 5/18/2008.. 5/13/2008.. 57512
59.16 524.45 51.96 50,61 5/7/2008 12... 5f19/2008.. 5/14/2008... $15.33
52.97 $7.95 S0.64 S0.20 5/7/2008 12.., 5/19/2008... 5/14/2008 ... s4.88
544,88 $120.00 59.60 £3.00 5/7/200812... 5/19/2008... 5/14/2008 ... £75.12

ory [ Internet Sales

5. Complete, you've created a calculated column using DAX that indicates the total profit

Optional: Add two more Calculated Columns using DAX

1. Product Standard Cost < 25% of Unit Price
a. Create an additional column



il GEd S

§|p

54.99
54.99
54,99
54,99
54.99
54.99
£3,578.27
53.578.27
53,578.27
$3,578.27
$3,578.27
$3,578.27
$3,578.27
$3578.27
£3,578.27
£3,578.27

“ P

© 200

Design

Name the column “ProductStandardCost <25%”

Apply DAX formula =[ProductStandardCost]<(.40*[UnitPrice])

Your results should look similar to the image below

Complete. You've created a Calculated Column indicating whether the Product

Standard Cost is less than 40% of Unit Price

= | PowserBived for Leeel - Book ] e

Advanced

Tata Ty STRUESFALSE s B SotSmallest o | argest rm— ¥ Autosum
J Tarmat st b Simallest lr “ e
From el PhvotTal i it by Fing
Database = Column =
et Extler (= Filles d
% =[ProductitandardCost]<{ 40° [UnitPrice]} =
it B3| Fraight B3| Catris inghlumb | CustomarPONumbe 2 it B3| DusD = | - IR - | ProductstandardCost <25% =] Add Column ~
$0.40 $0.12 6/22/20081... 7/4/2008... 5/29/2008 ... s3.12 | TRUE
50.40 $0.12 6/24/20081... 7/6{2008... 7/1/20081... §3.12 TRUE
50.40 50.12 7/4/2008 12... 7/16/2008... 7/11/2008 ... $3.12 TRUE
20,40 012 7f21/2008 1... 8/2/2008... 7/28/2008 .. 5312 TRUE
50.40 $0.12 7/22/2008 1... B8//2008.. 7/29/2008 ... 53.12 TRUE
$0.40 $0:12 7/24/20081... 8/5/2008... 7/31/2008 .. $3.12 TRUE
$0.40 50.12 7/26/20081... 8/7/2008... 3/2/20081... £3.12 TRUE
$286.26 589.46 7/2/2005 12... 7/14/2005... 7/5/20051... $1,406.98 FALSE
$286.26 589.46 7/14/20051... 7/26/2005... 7/21/2005 ... 5140698 FALSE
$286.26 58946 7/15/2005 1., 7/27/2005... 7/22/2005... $1,406.98 FALSE
$286.25 $89.46 F/17/20051,.. 7/20/2005... 7/24/2005 ... $1,406.98 FALSE
$286.26 589.46 8/5/2005 12... Bf17/2005... 8/12/2005 ... $1,406.98 FALSE
$286.26 589.46 8/7/2005 12... 8/19/2005... 8/14/2005 ... 51,406,985 FALSE
5286.26 589.46 8/10/2005 1... 8/22/2005... 8/17/2005 ... $1,406.98 FALSE
$286.25 $89.45 8/18/2005 1... 8/30/2005... 8/25/2005... 41,406.98 FALSE
$286.26 589.46 8/19/2005 1... B/31/2005... 8/26/2005 ... 5140698 FALSE
5286.26 589.46 9/5/2005 12... 9/17/2005... 9/12/2005... 51,406.98 FALSE <
~
N/
>
Product Subcategory | Internet Sales |

2. Product Standard Cost % of Unit Price

a.

@ 0 a00T

Create an additional column

Name the column “ProductStandardCost % of UnitPrice”
Apply DAX formula =[ProductStandardCost]/[UnitPrice]
Use the Apply Percentage Format button

Use the Decrease Decimal button twice

Your results should look similar to the image below
Complete. You've created a Calculated Column displaying
difference between Product Standard Cost and Unit Price as
a percentage

Data Type : Auto (Decimal Number) ~
Format : Percentage ~

4 =.0 .00
$-% > W0 3%

B1.. /4/2008%2 6/29/200
B1.. 7/6/2008... 7/1/2008
. e Z/1e/30N0g 2/11 /90
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l_]- e By ‘,5 Data Type : Autn [Decimal Mumber) = £ Sort Smallest to Largest W0
o .E, | _. b
& £ | B Format: Pereentage 5l son Largestro Smallest. ¥
From  Feom Dats brom Other — Fastng  Refresh  Fivotisble b ¥ [
Database™ Service™  Sources  Coonecionz | ¥ $-% » W43 Yo Geat Sart
Clipoars Get Ctesal Dana Feerralting Sort and Filtes

W oM T Elog
il Sortby Find
s Calumn ™ Wiew Wiew  Hidden Area

Slx

Uata  Diagram  Shaw  Caloulation

Tind. Calculations Wiew

|[Products... k- =z[ProductStandardCast]/[UnitPrice)
W Freight B3| CarrierTrackinglumber B3| CustomerPONumber £3) ProducttandardCo
3012 6/22/2008 1. 7/4/2008 .. 6/29/2008 .. §3.12 TRUE {
™ 50,12 6/24/2008 1... 7/6/2008.. 7/1/20081.. $3.12 TRUE
B osor 7/4/200812... 7/16/2008... 7/11/2008... $3.12 TRUE
= $0.12 7/21/2008 1. &/2/2008 ., 7/28/2008 ... | 5312 TRUE
5012 7/22f2008 1. &/3/2008 .. 7/29/2008.. 8312 TRUE
B s 7/24/20081... &/5/2008.., 7/31/2008... | s312 TRUE
B st 7/26/2008 1... §/7(2008 ... §/2/2008 1... $32 TRUE
B s 7/2/200512... 7/14/2005... 7/9/20051... 180685 FALSE
I seoas 7/14/2005 1... 7/28/2005.. 7/21/2005.. FALSE
I s8sas 7/15/2005 1... 7/27/2005... 7/22/2005 ... FALSE
0 ssuas 7/17/2005 1... 7/29/2005... 7/24/2005 ..,
] sesas '8/5/200512... 8/17/2005... 8/12/2005...
= 589.46 B/7/2005 12... B/18/2005.. Bf14/2005
589.45 B/10/2005 1... B/22/2005... Bf17/2005... |
I seaas 8/18/2005 1... £/30/2005... 8/25/2005
589.46 §/18/2005 1... B/31/2005... B/26/2005..,
i 539,46 9/5/2005 12... 8/17/2005... 9/12/2005 ... v
[ ] ~
]
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] <
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= Date | Guography | Product | Product Cotegory | Produnt Subcategory |lntemet Sales
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1. Select the first cell in the bottom grid section (aka the
“Calculation Area”) located just below the separation
line

2. In the formula bar, located at the top of the worksheet,

I
b |
il
o
l
H
L
<

| Customer | Date | Geography | Product | Produ

Record: W « 1 of 60,398 [

a. type the following: “Sum of Total Profit:=SUM([TotalProfit])

Eﬁ| uﬂ B (7 C) - % | PowerPivot for Excel - Book1.xlsx

Design Advanced

il ?—3‘-.:} Paste Append D | - |
1 — - _} n
[- . J:': Paste Replace = @ '{:)‘ ol
Paste B From From Data From Other  Existing Refresh
E[F) Copy Database > Service™  Sources Connections >
Clipboard Get External Data

[Product... ~ fe ‘Sum of Total Profit:=SUM([TotalProfit])

i383| OrderDat... 1 B3| DueDat... % 3| Ship)
530 20080726 20080807
311 20050702 20050714

. ProductKey




3. Right click the cell in the Calculation Area

4. From list, select Format
a. The Formatting window opens
5. Select the following in the Formatting window
a. Category = Currency
b. Symbol =§
c. Decimal places = 2

6. Click OK

7. Complete. You've created a Measure to sum the total profit

831 20050826 27918 1 100
Formatting ? X
Category:
General A | Symbol $ ¥ ‘
Number
TN ¥ |  Decimal places: 2 5

b 20050819 20050
ikl 20050905 20050
311 20050906 20050
314 20050906 20050
314 20050907 20050
311 20050916 20050
Bl | ot cex Y
Gt Copy Ctrl+C 2
|Sum of Total Profit: ... Pt Ctrl+V
Delete Del
Create KPI...

L4

Hide from Client Tools

Format...

Customer | Date | Geography
Record: ® + 1 of 60,398

Description...

Optional: Add another Measure

N~

—
Paste Append L y

Paste Replace
Paste From
Copy

Clipboard

[Product... ~ f

=z

& <

From Data From Other  Existing

Database ™ Service ™

Get External Data

i e
311
311
311
314
311
311

Sum of Total Profit: $12,080,883.65

Sources  Connections

5 B
20050805
20050807
20050810
20050818
20050819
20050905

Refresh  PivotTable

(8~
20050817
20050819
20050822
20050830
20050831
20050917

ubcategory | internet Sales

Click and Highlight the CustomerKey column
Then go to the AutoSum button and click the drop down symbol.
Select Distinct Count
Complete. You've created a Measure to count each unique customer key

Data Type: ™ SortAtoZ Ty ¥, AutcSum ~

Format: ~ SortZto A z Sum

$-9% » %2 % Clear Sort Cgei;i Cic_lf,f;‘lv Average
Formatting Sort and Filter Count

) Distinct Count
R~ b

20050812 Min
20050814 28014
20050817 28031
20050825 27681
20050826 27918
20050912 28182

Distinct Count of CustomerKey: 18484



Create a PowerPivot Workbook

1. Navigate back to your excel workbook to display your previously created PivotTable
2. Using the top Ribbon, go to Insert and then click the Power View button
3. Excel creates a Power View Sheet with your data model in the Field List

E W - Book1 - Excel
FILE HOME  INSERT ~ PAGE LAYOUT FORMULAS  DATA  REVIEW VIEW DEVELOPER  POWERVIEW  POWERPIVOT
x
ey
DOrag Helds hetw below
FILLDS
Sheet1 | Power View1 ® ] b

EE M -——+ 100%

4. In the Power View Fields list do the following
a. Go to Product. Select ModelName
b. Go to Internet Sales. Select OrderQuantity
5. Click where it says, “Click here to add a title” and type in “Order Quantities by Model
Name”.
6. Complete, you've created your another Power View report using your SSAS Tabular
Model



Filter the data in Power View using
Measure

1. In the Power View Fields Pane, Go to Product and find ModelName
2. Drag ModelName to the Filter pane
a. The table ModelName and its Columns will display under the Filter pane

Al

(Al

(Blank)

All-Purpose Bike Stand
Bike Wash

Cable Lock

Chain

Classic Vest

Cycling Cap

Fender Set - Mountain
Front Brakes

Front Derailleur
Full-Finger Gloves
Half-Finger Gloves
Headlights - Dual-Beam
Headlights - Weatherproof
Hitch Rack - 4-Bike

HL Bottom Bracket

HL Crankset

HL Fork

HL Headset

HL Mountain Frame

HL Mountain Front Wheel
HL Mountain Handlebars
HL Mountain Peda

3. Click on the Advanced Filter Mode button next FHEE
to ModelName in the Filter pane VIEW

4. In the text box under contains type “tire”

5. Click apply filter

6. The Power View table displays the order

quantities for tires only contains
7. Complete, you've applied a filter to your Power [tre
View table i

apply filter



Order Qua

ModelMame OrderQuantity «
HL Road Tire E;SB
LL Mountain Tire 862
ML Road Tire 926
Touring Tire 035
LL Road Tire 1044
ML Mountain Tire 1161
HL Mountain Tire 1396
Touring Tire Tube 1488
Road Tire Tube 2376
Mountain Tire Tube 3095
Total 14141

Visualize your Data

1. Click the table
2. Go to the Design tab in the Ribbon
3. In the Switch Visualization section, click the Other Chart button

Table Bar Column Other Map  Tiles
*  Chart~ Chart~ Chart ~ ype
Switch Visualization Tiles Slicer

Other Chart

Switch the visualization for this data
region to another type of chart.

|‘_—.E, Power View

Tell me more



4. The table changes to a chart with a legend

Order Quantities by Model Name

B HL Mountain Tire
Bl HL Road Tire

LL Mountain Tire
B LL Road Tire

ML Mountain Tire
B ML Road Tire

Mountain Tire Tube
B Road Tire Tube

Touring Tire

Touring Tire Tube

5. Right click the chart and select the Copy option
6. Right click the chart and select the Paste button
a. A duplicate chart is created
7. Click on one of the charts and then using the top Ribbon:
a. select the Column Chart button in the Switch Visualization section
b. Select Stacked Column, which changes the visualization to a different chart type

Note: Interactivity: By clicking on any part of either chart, the visualization will interact and
react to your selection by highlighting/emphasizing your specific
Note: Interactivity: Direct your mouse/pointer to any portion of your chart - PowerView will

display additional data about that specific section

Note: Use the Filters pane to change data is displayed in your visualization what is displayed in
your charts

Note: You can change or add to the view by making additional selection from the Power View
Fields pane

8. Click the Save button
9. Complete, you've created a Power View visualization of your analyzed data



Order Quantities by Model Name

OrderQuantity by ModelName

ModelName
B HL Mountain Tire
I HL Road Tire
B LL Mountain Tire
B LL Road Tire
0 ML Mountain Tire
B ML Road Tire

- Mountain Tire Tube
I Road Tire Tube
0 Touring Tire
Touring Tire Tube

1
OrderQuantity by ModelName

HL Road LL Road ML Road Mountain  Read Tire Touring Tire Touring Tire
Mountam Tire Mountam Tire Mountam Tire Tire Tube Tube Tube
Tire Tire Tire
i - J

3K

(Thous an(l:;}

Optional: Power View Themes

8. Using the top Ribbon, click on the Power View tab  pu ik LAYUU | FURMULZ
9. Inthe Themes section there are several options

that allow you to further change your visualization Aﬂj Font~
EETEEN

. Th i
2 Foiges A 1Text Size -
' , Themes
c. Text Size &) Background ~

d. Background
10. Utilize each option to further enhance your Power Themes
View Visualization

11. Using the top Ribbon, click on the Layout tab
12. In the Labels section there are several options that allow you to further change your

visualization
|
— a0
[j I i1=

Title legend Data Map
v *  labels ~ Background
Labels



Title
Legend
Data Labels
d. Mao Background
13. Utilize each option to further enhance your Power View Visualization
14. Complete, you’ve further enhanced your Power View report

o T o



